pkg_socialads_v4.0.0_9cfc9d88

Version 4.0.0
Maturity Stable
Release Date 2022-03-29 05:30
Unfortunately you do not have access to this file.

 

NOTES:

  • Take a complete backup of your site using tools like 'Akeeba Backup' before installing or upgrading.
  • We have updated multiple Plugin Triggers to make¬†Social Ads¬†compatible with Joomla 4. So if you are using any custom plugins with old trigger names, you may need to update their code
  • We recommend to NOT update¬†Social Ads¬†to Joomla 4 compatible version on your sites if you are using other Techjoomla extensions which are not Joomla 4 compatibility yet (like¬†JTicketing, Quick2Cart, Shika, People Suggest etc)

Social Ads v4.0.0 - changelog

+ Feature Added (2):

  • Joomla 4 compatibility (Common compatible package for J3.10.x and J4.0.x)
  • Updated Bootstrap support as
    • On J4.0.x
      • Bootstrap 5 on backend
      • Bootstrap 5 on frontend
    • On J3.10.x
      • Bootstrap 2 on backend
      • Bootstrap 3 on frontend

Updated Plugin Triggers

Old trigger name New trigger name
saOnAfterOrderStatusChange onAfterSocialAdOrderStatusChange
saOnAfterCampaignSave onAfterSocialAdCampaignSave
saOnAfterCampaignChangeState onAfterSocialAdCampaignChangeState
saOnAfterZoneSave onAfterSocialAdZoneSave
onPromoteData onSocialAdPromoteData
saOnAfterAdIgnore onAfterSocialAdIgnore
addTax onAfterSocialAdAddTax
OnAfterGetAds onAfterSocialAdGetAds
saOnAfterCampaignDelete onAfterSocialAdCampaignDelete
saOnAfterAdSave onAfterSocialAdSave
OnAfterGetEstimate onAfterSocialAdGetEstimate
saOnAfterAdChangeState onAfterSocialAdChangeState
saOnAfterAdDelete onAfterSocialAdDelete

Compatibility at the time of release:

  • Joomla v3.10.x, Joomla v4.1.x, PHP v5.6.x, v7.0.x, v7.1.x, v7.2.x, v7.3.x, v8.0.x
  • EasySocial v3.2.24
  • Jomsocial v4.7.8

New Installation Instructions:

  • Download the latest version of the¬†SocialAds from the Techjoomla website
  • Install the downloaded¬†SocialAds¬†using the Joomla Extension installer

Upgrade Instructions if you are upgrading from 3.4.x:

If you have overrides for email constant, please make changes in the administrator -> SocialAds -> Notifications Template and change notifications emails.

If you have not installed the MaxMind's GeoLite2-City.mmdb yet then follow the steps given below.
- 1) Login or create account on MaxMind. Click Here
- 2) Go to My License Key page and create license key if not created earlier.
- 3) Go to Download Files page and download GeoLite2-City gzip file.
- 4) Unzip or uncompress the downloaded file.
- 5) Place the file 'GeoLite2-City.mmdb' to location 'your_domain/plugins/system/tjmaxmind/db/'.