Installation and upgrading guide

Installation

For EB version 1.5.1 onwards 

* indicates optional steps

  1. Download the latest version of Email Beautifier component from the download area.
  2. Install the downloaded the package using the Joomla Extension installer directly. All required plugins are packed together for the ease of installation. This is single installer package that you can install using the Joomla Package Installer. 

    Extensions included in the Email Beautifier Package are auto-installed when you install the component.

    - The Email Beautifier core component - com_emailbeautifier

    - Email Beautifier-Mailer system plugin - plg_sys_eb_mailer

    - JMailAlerts Integration System Plugin - plg_sys_jma_integration

  3. *  If you want to use J!MailAlerts(JMA) plugins in your Beautifier emails, then those JMA plugins should be enabled. Note that J!MailAlerts component is NOT needed to use JMA plugins inside Beautifier. You need to enable this plugins 'JMailAlerts Integration - System Plugin (plg_sys_jma_integration)' for using JMA plugins.
  4. * Note that the same plugin 'JMailAlerts Integration - System Plugin (plg_sys_jma_integration)' is also needed if you want to show Ads in your Emails via SocialAds.

Upgrading

For EB version 1.5.1 onwards 

- Simply install the component on top of the earlier installation. All your settings shall be saved.

For EB version older than 1.5.1

If you are installing the component on the top of version 1.0.8, you will found "Failed deleting config_default.php" message.

Don't worry about this message, your component is installed successfully :)

Let's talk about old template backup 

If earlier installation version is 1.0.8, we are trying to take backup of your old template. Your old template back up will found at  "your_site/components/com_emailbeautifier/templates/oldTemplate_bk". Your old template is kept as default template and you can use it later for creating new templates.

Subscribe to Newsletter





Marketing permission: I give my consent to to be in touch with me via email using the information I have provided in this form for the purpose of news, updates and marketing.

What to expect: Jump on to our Newsletter & stay updated on news on our extensions, new releases & offers! 

* If you wish to withdraw your consent and stop hearing from us, simply click the unsubscribe link at the bottom of every email we send. 


Latest Blogs

Fan Speak !

  • If you think seriuosly about building your own community, it's one of the extensions that you must have! Great and very easy setup with very nice options!

    Moreover, if you have any problem, Techjoomla has fantastic support!!

    Compatible with JomSocial 2.8.4 too!