Parth's Blogs @Techjoomla

1 minute reading time (247 words)

Techjoomla and Bootstrap 3

Techjoomla and Bootstrap 3

The Bootstrap 2.3 vs Bootstrap 3 Problem

As of now Joomla uses Bootstrap 2.3 as the officially supported library. However template developers have started adopting Bootstrap 3 in their frameworks & templates. Originally it was hoped that Bootstrap would help get a unified user interface for Joomla. Currently Joomla extension developers are hard pressed to support both 2.3 & 3 in their extensions. 

Doing this means that either extension developers will need to provide alternative layouts for Bootstrap 2.3 as well as as for Bootstrap 3. This however might not always be practical. We need a better solution. 

Exploring for a Solution with the Community

Techjoomla is helping organize a Extension & Template developers group to bring a more sustainable solution to this problem. In an ideal world extension developers would be able to concentrate on the Business logic code & innovate in functionality while letting template developers be innovative in creating awesome designs. For now a solution is being sought on the group to have an unified & standard way for extension devs to offer both BS 2.3 & BS 3 to end users. 

What if i want Bootstrap 3 Now ?

Till that happens, we are recommending that you use the method suggested by Joostrap to convert Bootstrap 2.3 to Bootstrap 3.0 using No Number's ReReplacer plugin.  We have found this the most painless way to get Bootstrap 3 to work immediately with our templates. 

So if you want Bootstrap 3 now, this is the way to go.

3
Maximizing your Advertising Real Estate with Socia...
Planning the Quick2Cart 2.2 Release! Tell us what ...